Error 500 After TLS 1.2 Guide



I got an Error 500 After enableing the TLS 1.2, by provided guide.
And the error stays even after disabeling TLS 1.2.

/connect, /remote, ALL sites give Error 500.
even http%servername% (usuallt gives an IIS Basic welcome page)

I did the asked reboot after the Enabkeing and Disabeling of the server.
Funny thing is, Client Backup still functions ok, and Folder are still ocupied with files (asuming they work)

Is there an step by step control sheet of what edits this software makes?

or can someone provide me the basic settings of the IIS server and folder?

Enabling TLS 1.2 On Windows Server Essentials

Reinstall isnt an option on a running DC with Clients

  • You must to post comments.

Alas, I have no idea what could be going on there seeing as I’m not able to replicate that issue over here on any of our in-house test servers (i.e. the feature works just fine for us here, and to date, no one else has reported a similar issue/error that I am aware of). As for exactly what the feature does… It simply runs the following script on the server (and unrolls it when you tun the feature off again):

Setup Microsoft Windows or IIS for SSL Perfect Forward Secrecy and TLS 1.2

If you opt to disable TLS 1.0 as well, then that is also performed via the above script, and the “SchUseStrongCrypto” and “SystemDefaultTlsVersions” settings are added to the registry as per Microsoft’s guidelines here:

Transport Layer Security (TLS) best practices with the .NET Framework

Sorry that I don’t have a better answer for you on this one.

  • You must to post comments.

Im also sorry for having issues with the RemoteApp software.
its fairly sure that during the disabeling of the TLS 1.2 specs, the software broke a few IIS options.

I just found out that:

using %servername%

BOTH give an 500 error,




BOTH are working (showing/displaying atleast)

I dont have a client to retest the working of the connector software.


probably 1 of the bugs is, when you ‘disable’ HSTS, the option of actually disabeling wont work.


The 2 greyed-out boxes are indeed ACTIVE on:

IIS > Default Website > Action section > Advanced Settings > HSTS tab


The only issue now is why does the IIS only work on IP level?
where did the ServerName go to?

  • You must to post comments.
Showing 2 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox