Connected computers not getting published


Hi, Mike,

I uninstalled WSE RemoteApp and WSEE from my WS16 server. I then stood up a WS22 server, installed WSEE, built a new domain, and installed WSE Remoteapp on it.

I removed my workstation and a temp VM from my old domain and connected them to the new WS22 server. I added them to my user account in the Computer Access. I also published Windows Explorer, Command Prompt, and Google Chrome. (This is a temp server, so I won’t publish anything else on it. I’m really just testing functionality.)

Although the WSEE server health seems perfect (all green checks across the board), I can see the published apps in my Launcher, but the published computers are missing.

What I am missing or doing wrong?

Best regards,

Edgar T.

N.B.  I tried adding a couple of screenshots to show the connected computers, that I’d assigned them in the computer access tab, and that they were missing from the WSE RemoteApp Launcher, but I kept getting a Forbidden message. I can forward them to you via email, if you like.

  • You must to post comments.
Good Answer

Client computers that are connected to your Essentials server (i.e. those computers on which you’ve installed the Windows Server Essentials Connector software – whether they’re joined to the domain or simply connected via Microsoft’s SkipDomainJoin connection method) will not appear within the WSE RemoteApp Launcher window.

That being said… You can have your connected client computers appear within WSE RemoteApp’s RADC web feed as described in the following article:

Adding Desktops To The RADC Web Feed

Also, for a bit more information on WSE RemoteApp’s RADC web feed feature see:

Connecting From Mac / iOS / Android / Windows Computers and Devices

EDIT: Although… If you would like your client computers added to the WSE RemoteApp Launcher, then you can always just publish RDP files (or shortcuts to the RDP files), which initiate a standard Remote Desktop connection to the client computers (i.e. the same RDP files that you would download when you attempt to connect to the client computers from within the “Devices” section of the Essentials server’s Remote Web Access website at, etc.). The only real caveat to doing it that way (as opposed to using the RADC web feed) is that the remote session initiated with the client computer from the RDP file that’s published within the WSE RemoteApp Launcher window would be a nested session. This is exactly what WSE RemoteApp’s “Publish server desktop” task does when it publishes the server desktop for you.

  • You must to post comments.

Thank you, as always, for your thorough responses, Mike.

I have done this so many times over the years, so I had followed almost all of the instructions you resent. (That’s what I had in the screenshots I was unable to upload.) The one piece I’d forgotten was to actually Enable the RADC Web Feed. SMH

I’m all set!

Best regards,
Edgar T.

  • You must to post comments.
Showing 2 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox