WSEE Installer failing



I am trying to install WSEE using your Installer, onto a fresh out of the box Windows Server 2019, and no matter what I try (not updating 2019, after updating 2019, license ver, trial ver) it ALWAYS fails at 89%. Any ideas please?


  • You must to post comments.
Good Answer

I assume that you mean that Microsoft’s “Configure Windows Server Essentials” wizard is failing there (and not the WSEE Installer itself). If so, then I’m not exactly sure what could be happening there seeing as I’ve just tested installing WSEE on a brand new/clean (straight out-of-the-box) installation of Windows Server 2019 (with all of the latest Windows Updates installed, and no other server roles, features, or applications installed), and everything is working just fine for me here. I’m also not seeing any other users reporting such an issue at this time.

About all I can tell you to do is to try starting over completely from scratch again with a brand new/clean installation of Windows Server 2019 and see what happens.

Other than that, you can try looking within the server’s “Logs” folder to see if any of the log files in there happen to list something that gives you a clue as to why the config wizard is getting stuck at 89%. You can find the Logs folder at the following location on the server:

C:\ProgramData\Microsoft\Windows Server\Logs

I typically sort the folder by date modified and then start looking through the log files from top down. You can open the log files in Notepad, and the newest entries will be listed down at the very bottom of the file (so start there and then move upwards looking for any clues as to what might be causing the problem).

You can also try opening the Event Viewer applet (Control Panel → Administrative Tools → Event Viewer) and taking a look in the Windows Logs → Applications and Applications and Services Logs → Microsoft → Windows → Server Essentials Deployment → Deploy log files just to see if they happen to show anything in there as well.

  • You must to post comments.

Hello Mike, thanks for the response, and for your work putting this tool out there for us.

But it seems it is just not working for me. I have tried this now 6 or 7 times, each time from scratch, fully updated, no roles or features added, as you specify – I just let the install run, and then each time @89%, failure with “An error occurred while configuring Windows Server Essentials. Please try again.”. The last two times from scratch I even formatted the disk before starting to make sure ‘clean’ was really ‘clean’!

As you say, the installation itself seems to go ok, then

  • launches ‘Configure Windows Server Essentials’,
  • I enter the Co name, domain name, admin name, password, etc. restarts,
  • asks for permission for Windows Server Essentials Server Role Configuration Wizard’ to launch (with your name as certifier), restarts again,
  • comes back with ‘applying computer settings’, (for fair few minutes…)
  • returns to ‘Updating and preparing your server’ until it gets to 89% when it fails.

In the log files, the only one which may be of interest perhaps is an ‘error’ log file that states “FATAL: InitializeStorage:” I understand the statement but not what it refers to and if it is related? (It’s a 1Tb disk so definitely not a space issue.)

The event viewer logs you specify show nothing but information markers as would be expected – no errors.

I have run out of ideas. Just gone through it all again from scratch (to script the above) and exactly the same result again.

I have no idea where to go from here.


  • You must to post comments.

Is the 1TB system drive formatted as NTFS? If not, then try formatting it as a NTFS drive instead.

Are you using Storage Spaces, or any other drive pooling software? If so, then try eliminating it.

If your SATA controller is running in ACHI mode, try switching it over to RAID mode instead (from within the BIOS).

Maybe try deleting the partition table on the drive and recreating it.

Try using a different drive altogether.

From the sounds of it, there appears to be some kind of a hardware/software based drive/storage issue going on there, which doesn’t really have anything to do with the WSEE Installer per se I’m afraid.

  • You must to post comments.

Thanks, Mike.

Although the things you suggested were already as suggested, you did inadvertently point me to the problem. The disk was set to Dynamic. This did not stop the 2019 Server Std from being installed correctly, but it clearly did not agree with the Essentials elements.

Reset it to Basic, and away it went, all sorted. Just thought I’d let you know.


  • Mike
    I’m glad to hear that you managed to figure out what was causing the issue, and finally get WSEE installed. Thank you for letting everyone know how you got it resolved. Enjoy using WSEE on Windows Server 2019!
  • You must to post comments.
Showing 4 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox