WSE RemoteApp rejects userID/password


Hello. I’m running WSE RemoteApp in WSE2016. My laptop is in the domain and the server is both DNS and DHCP server.

RemoteApp has been running fine until last night, when I logged into my WSE Remote Access web page. I had not used that for a long time, but it works.

Coincidentally, I changed my network password. My two computers both required me to lock out and log in with my new password, and it works.

I can access server folders and I’m typing my user ID and new password correctly in the RemoteApp screen, but it fails. If I use RemoteApp by way of the Remote Access web page, it works fine.

Does anyone have a suggestion for how to fix this?

  • You must to post comments.
Good Answer

Did the client computer recently get updated to Windows 10 v2004 via Windows Update (to check, just run WinVer.exe on it)? If so, then that probably caused the client to disconnect from the server (seeing as this is a known issue/common problem when installing the big Windows 10 “feature updates”). You’ll probably just need to reconnect the client to the server again by going to http://<YourServerName>/connect and then downloading and running the Windows Server Essentials Connector software setup program on it again in order to fix the issue.

Just be aware that since your client computer is domain-joined, you’ll probably want to add the following registry key to it, BEFORE you run the connect software again, and then delete it afterwards:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\ClientDeployment

SkipDomainJoin = 1 (DWORD)

Doing that will stop the connector software from joining the domain all over again, and blowing away your current user profile.

  • You must to post comments.

So signing in remotely via the server’s Remote Desktop Gateway is working fine, but signing in locally via the WSE RemoteApp connector is not working… I’m afraid that I’ve never come across that one before. Have you tried rebooting BOTH the server AND the domain-joined client computer just to see if that happens to shake things loose for you?

  • You must to post comments.

Hmm… WSE Launchpad says the server is offline and I’m not logged in, but I have access to the server folders.

  • You must to post comments.

Rebooting fixed it on one, but not on another. The computer that worked was already updated to 2004. The other just updated yesterday. After attempting to connect it showed as connected but, when I attempted to open WSE RemoteApp Launcher, it switched to offline. I then ran the connect utility again after setting the reg key as above. Same result, even after rebooting the laptop again.

It’s a drastic approach but I may rebuild the server. I was thinking of doing that, anyway. When I first set it up I used domain.local as the domain and that interferes with remote connections. I’ll recreate it without the .local suffix.

It’s not hard for me to redo the server because I use DrivePool for data storage. I can reinstall on the OS drive without data drives, then reinstall DrivePool. When I put the drives back in, DrivePool will recognize them and rebuild it. All I have to do is rearrange the drives. (That’s how I recovered the data from WHS after installing WSE 2016.)

I don’t expect it to be plug and play but I won’t lose anything, and I have plenty of time on my hands.

I’ll make sure I have a screen shot of my drives and shares so I can rebuild them as the same, and keep copies of the few software keys I have on the server.


  • Mike
    I’m afraid that I don’t know enough about top-level domain (TLD) suffixes to argue for or against using a .local domain suffix on Essentials. However, I can say that I’ve never once come across any issue whatsoever when using one (since using .local is considered best practices by Microsoft, and that’s how they configure all Essentials servers by default/out-of-the-box). That being said… Microsoft does indeed provide a way for you to specify the domain suffix that you want to use within the Configure Windows Server Essentials wizard (or via the Start-WssConfigurationService PowerShell cmdlet). Good luck!
  • SomebodyInGNV
    When attempting to connect by VPN, it wouldn’t recognize my username or domain/username but sometimes would recognize domain.local/username, which is very confusing.
  • You must to post comments.
Showing 4 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox