Work folder



I would try this work folder feature, but I cannot deal with port 8443 what I port forwarded to server’s ip.

I have anywhere acces configured which working well (remote web acces), and the work folder working and syncronizing between server and devices.

This 8443 port means I could acces my files over internet browser (http://domain:8843) or?

I need to do some things on iis manager to bind port 8443 or?

Can you help me to resolve that issue?



  • You must to post comments.
Good Answer

Sorry, but I’m not quite following what you’re asking (or wanting to know) here.

By Microsoft’s design, Windows Server Essentials is a web server. It utilizes port 443 to implement its Anywhere Access/Remote Web Access functionality. Microsoft’s Work Folders server role is also implemented as a web server that utilizes port 443, and so it cannot be used under Windows Server Essentials unless you bind it to a different (non-conflicting) port.

Since the Windows Server Essentials Anywhere Access/Remote Web Access functionality sets up a secure website on your server (e.g., etc.), we simply piggyback the Work Folders server role on that existing functionality by binding it to a different port (e.g., etc.). All of that is handled for you by the WSE WorkFolders add-in. You simply tell it which port you want it to use (with the default port being 8443), and it takes care of implementing everything for you. If you don’t want to use port 8443, then you can simply inform it to use another one instead.

The only things you need to do in order to get Work Folders to work on your Windows Server Essentials server is to make sure that Anywhere Access/Remote Web Access is properly configured on your server (and set up with a valid SSL certificate), install the WSE Work Folders add-in on the server, and then run the add-in’s “Enable Work Folders” task and follow the prompts. After that, you can connect your Work Folders clients to the server using the Work Folders URL you’re provided with by the add-in (e.g., etc.). All of the details can be found here:

WSE WorkFolders 2016 / 2012 R2

  • You must to post comments.

Thanks you for your answer.

Sorry for my language, quite confuse.

So, anywhere access working well. Remoteapp which I implemented from your webpage is fine.

After I installed work folder, port forwarded 8443 to my server ip’s. and try with mydomain:8443 (attachment 1 appear). I can configure work folder from control panel on every client computer and files copy/sync to wsesyncshare, but cannot step (attachment2), then if I press close then (attachment3).

If I try this to many times work folder from windows server roles installed and put over remote web acces and have to remove to acces remote web again.

But how I say sync is ok, but work folder means to acces files over a browser this function is broken.

  • You must to post comments.

Work Folders cannot be accessed directly from a web browser (seeing as Microsoft did not design it that way). Rather, you must use one of the Microsoft-provided Work Folders clients in order to access your work files instead.

Microsoft currently provides three Work Folders clients:

1. The native “Work Folders” Control Panel applet that’s located in the client editions of Windows 8.1 or Windows 10. SEE:

How to Set Up and Use Work Folders in Windows 8.1/10

Or, if you’re still using Windows 7:

Work Folders for Windows 7

2. The Work Folders for Android app.

3. The Work Folders for iOS app.

You simply need to enter your Work Folders URL into any of those Microsoft-provided Work Folders clients, and you will then be able to access your work files from there.

And, as I mentioned previously, all of this is covered in the following article:

WSE WorkFolders 2016 / 2012 R2

  • You must to post comments.

But then why get error message 2 (attacment 2)?


  • You must to post comments.

WSE WorkFolders attempts to ping the Work Folders URL to see if it can get a response back form it (in order to determine if your chosen port (8443, etc.) is properly forwarded through your network router). If it doesn’t get a response, then it puts up that message (alerting you to address the issue within your router, etc.).

However, since your message 1 (attachment 1) shows that the Work Folders URL is responding when you enter it into a web browser, it should indeed be working for you.

Have you allowed access for one of your users (via the “WORK FOLDERS” page of the server Dashboard), and then tried setting up a Work Folders client for the allowed user using your Work Folders URL yet?

How to Set Up and Use Work Folders in Windows 8.1/10

  • You must to post comments.

Everything work fine.

I don’t know why this error message. 8443 port is open and I can verify this with an online open port checker. Port forwarding ok.

I have users with work folder, and yes the work folder from computer sync with d:\wsesyncshare.

Only the error message.

  • Mike
    Well, as long as everything is working, then I wouldn’t worry about that (warning/information) message. It’s simply letting you know that it couldn’t ping your Work Folders URL via the port that you’ve chosen, and so it’s simply informing you to open your network router settings and validate that the port is indeed open and being forwarded to the IP address of your Essentials server. Since it obviously is in your case, then you should be good to go. ;-)
  • You must to post comments.
Showing 6 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox