Unable to install wse Remote App 2016



I’m trying to install WSE RemoteApp 2016 on my Windows Server 2016 Standard DC, but it fails saying:

“the add-in package cannot be downloaded. Ensure that your network connection is working correctly and then try again” I can confirm my network is fine.

I also tried this at two different sites on 2012 r2 but also failed.

can anyone help ?

  • Steven Tingate asked 8 years ago
  • last edited 8 years ago
  • You must to post comments.
Best Answer

disregard the last answer, the server essentials services were stopped


tried to run the installer again, and it susceeded

thanks for your help!


  • Mike
    Glad to hear that you got WSE RemoteApp 2016 installed. Thank you for letting everyone know how you corrected the issue. I have heard several reports of the Essentials services not starting properly under Windows Server 2016. Hopefully it’s something Microsoft will get fixed in an update.
  • You must to post comments.

WSE RemoteApp requires the “Windows Server Essentials Experience” (WSEE) server role under Windows Server 2016/2012 R2 Standard or Datacenter. Ensure that the WSEE server role is installed on your server(s) before attempting to install WSE RemoteApp 2016/2012 R2.

  • You must to post comments.

Hi i have confirmed that this roles are installed



  • You must to post comments.

Are you using the latest version of WSE RemoteApp 2016 (which, as of this writing, is Version 1.255.1271.1)? If not, then you can download the latest version from here.

Are you using the final (RTM) release of Windows Server 2016 Standard (i.e. not one of the older technical previews)?

Are you attempting to install WSE RemoteApp 2016 from one of your client computers, or directly from the server itself? If from a client computer, then you need to make sure that the client computer has the Windows Server Essentials Connector software (i.e. the Launchpad) installed on it, and that it is properly connected to the server (i.e. go to: http://servername/connect). Otherwise, you can try installing WSE RemoteApp 2016 directly from the server instead (i.e. copy “WSERemoteApp2016.wssx” over to your server and then run it from there instead of attempting to run it from one of your client computers).

  • You must to post comments.

Thanks for the tips


I downlaoded the latest version and tried that, but get this eror

This is a server 2016 standard not upgraded from the technical previews

thanks for all your help!

  • You must to post comments.
Showing 5 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox