Sync Stopped. Can't Encrypt Files


We have downloaded, installed, deployed and setup WSE Work Folders. All client laptops run Windows 10 Enterprise x64 v1903. We use Server 2016 Essentials.

Machines setup to use Work Folders as instructions but all machines have a sync error that will not clear.

Screenshot attached. App on iPad / iPhone works fine.

Have tried removing and re-adding account. Disabling UAC. Disabling AV software. Have checked that compression is not enabled on the Work Folder directory – it is not.

Any thoughts?

  • You must to post comments.
Good Answer

Unfortunately, it looks like there’s a bug Windows 10 1903 when it comes to encrypting work files over on the client-side (i.e. via the native Work Folders sync client applet). For a bit more info see:

Work Folders can’t encrypt files on Windows 10 1903

Workfolders Issues on 1903

From what I can gather, it looks like Microsoft is aware of the issue, but who knows when they’ll fix it (seeing as there’s no official response from them anywhere). We haven’t yet upgraded any of our Windows 10 clients to 1903 since it appears that it’s just not quite ready for prime time (especially with all the problems folks are having with getting the Windows Server Essentials Connector software to work after upgrading to 1903!). Microsoft always seems to make it really painful for their early adopters (sigh).

You’ll need to stick to using the iOS/Android/Mac clients until Microsoft steps up and fixes the issue under 1903. Sorry that I don’t have a better answer for you on this one, but that’s just how things go in Microsoft’s newfangled Windows 10 world I’m afraid.

  • You must to post comments.

Thanks. Looks like your right….

Going into the server role and changing the properties on the WseSyncShare folder so that Encrypt Work Folders is unchecked… it springs into life and works… obviously with inherrent security issues.

  • Martyn Hudson answered 5 years ago
  • last edited 5 years ago
  • Mike
    Yes, that makes sense. However, as you’ve mentioned, that’s not really a recommended solution since it’s much more secure to have the work files encrypted while they’re at rest over on the client. Hopefully Microsoft will get this one fixed soon. I’ll definitely be keeping an eye on the issue and I’ll post an update here just as soon as I know something more. Thanks for bringing the issue to everyone’s attention.
  • You must to post comments.

Just a quick update…

It’s going on close to a year now and Microsoft still refuses to fix this nasty bug in the native Work Folders client on Windows 10 v1903, v1909, and (most likely) v2004. I’m absolutely flabbergasted and don’t know what else to say (other than shame on them).

If you’re setting up a new Windows 10 client machine, and you want to use the native Work Folders client on it, then I suggest that you install Windows 10 v1809 on it, set up the native Work Folders client, and then update it to Windows 10 v1903 (or greater).

Other than that, if you absolutely need to use the native Work Folders client on Windows 10 v1903 (or greater), and you can’t start off with v1809 (or older), then all you can do at this point is turn off the (at rest) file encryption feature on your Work Folders sync server, and then just use Work Folders without (at rest) file encryption.

Obviously, that’s a pretty crappy solution, but until Microsoft gets around to fixing the file encryption bug in their native Work Folders client, there’s not a whole lot that I can do about it I’m afraid. The only thing I can tell you is, if you’re going to disable (at rest) file encryption for your Work Folders, to make sure that all of your devices have encryption enabled at the device level (such as by turning on BitLocker in Windows 10, enabling device encryption on your mobile devices, etc.).

Here’s how to turn off Work Folders file encryption on your Essentials server:

1. Sign in to your Essentials server as an administrator.

2. Open the Server Manager (i.e. Control Panel -> Administrative Tools -> Server Manager) and go to:

File and Storage Services -> Work Folders

3. Right-click on the existing “WseSyncShare” sync share and then choose “Properties“.

4. In the “WseSyncShare Properties” window that opens, click on “PC Security Policies“.

5. Uncheck the “Encrypt Work Folders” check box and click on the “OK” button to save your changes.

After doing that, you “should” then be able to set up a brand new Work Folders connection using the native Work Folders client on your Windows 10 v1903, v1909, or v2004 computer(s). Just be aware that if your ever happen to re-run the “Enable Work Folders” task on the “WORK FOLDERS” page of the server Dashboard, then the encryption feature will automatically get turned back on again for your server (seeing as WSE WorkFolders is designed to always force encryption in your Work Folders clients).

Once (if) Microsoft gets around to fixing the problem, then you can turn client-side encryption back on again by simply reversing the steps given above.

Ya gotta love Microsoft! If it doesn’t involve emoji, colorful app icons, dark themes, or ninja cats, then they just don’t care about it in Windows 10. Oy!

  • You must to post comments.

Another quick update…

I can now confirm that Microsoft has finally fixed this atrocity of a bug in their upcoming Windows 10 v2004, Build 19041 release (i.e. the “May 2020 Update“) that’s currently scheduled to be released on the 12th of this month (I believe).

It’s a real shame that it has taken Microsoft more than a year to get around to fixing this bug, but I’m glad that they finally have. Now it only remains to be seen if they will back port the fix to the older Windows 10 v1903 and v1909 releases (I’m certainly not holding my breath for that though).

So… If you want to use the native Work Folders client (with at rest encryption of your work files) in Windows 10, then you’ll need to go ahead and install the “May 2020 Update” once it becomes available via Windows Update.

  • You must to post comments.
Showing 4 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox