reinstall WSE RemoteApp 2012 R2 with errors


Hello, when i try to reinstall WSE RemoteApp 2012 R2 on the Server the installation ends with an error.


Protokollname: Application
Quelle: MsiInstaller
Datum: 27.04.2018 11:23:34
Ereignis-ID: 11920
Ebene: Fehler
Benutzer: SYSTEM
Computer: Server.JARKOW.local
Product: WSE RemoteApp 2012 R2 Windows Server Solutions Add-in — Error 1920. Service ‘WSE RemoteApp Provider Service’ (WSERAProviderService) failed to start. Verify that you have sufficient privileges to start system services.
<Event xmlns=””>
<Provider Name=”MsiInstaller” />
<EventID Qualifiers=”0″>11920</EventID>
<TimeCreated SystemTime=”2018-04-27T09:23:34.000000000Z” />
<Security UserID=”S-1-5-18″ />
<Data>Product: WSE RemoteApp 2012 R2 Windows Server Solutions Add-in — Error 1920. Service ‘WSE RemoteApp Provider Service’ (WSERAProviderService) failed to start. Verify that you have sufficient privileges to start system services.</Data>

In Services i become an error 3  that the path coud not be found

i run the installation as an Domain Admin


  • You must to post comments.
Good Answer

I’m afraid that I’ve never come across such an issue when (re)installing/updating WSE RemoteApp before.

WSE RemoteApp installs a system service onto your Essentials server named “WSE RemoteApp Provider Service” (WSERAProviderService), and based upon the error log that you’ve provided, it appears that the installer does not have sufficient privileges to start the service once it has installed it on the server.

Have you locked down your Essentials server (or more specifically the TrustedInstaller user account) in such a way that it cannot start services that logon as the Local System account? If so, then you’ll need to undo that in order to allow WSE RemoteApp’s installer permission to start the “WSERAProviderService” service under the Local System account.

Other than that, are you running WSE RemoteApp 2012 R2’s installer (i.e. WSERemoteApp2012R2.wssx or WSERemoteApp2012R2.exe) from one of your connected client PCs, or are you running it directly from the Essentials server itself? If you’re running it from a connected client PC, then try performing a standard Remote Desktop connection to your Essentials server, signing in as a local administrator (not a domain admin), and then executing the installer directly from the local administrator’s server desktop instead.

Lastly, have you tried completely uninstalling any existing WSE RemoteApp installation and installing the add-in from scratch again?

To uninstall any existing WSE RemoteApp installation:

Open the server Dashboard, go to the “APPLICATIONS” page, select (i.e. highlight) “WSE RemoteApp” in the list of installed add-ins, and then click on the “Remove the add-in” task and follow the prompts.

NOTE: If the “WSE RemoteApp” add-in isn’t listed in the list of installed add-ins, then you’ll need to do the following in order to uninstall it:

1) From a local administrator’s server desktop, open the Registry Editor (i.e. right-click on Start -> Run -> regedit.exe), and go to the following registry key branch:


2) Look through the subkeys of that branch until you find the one that’s for WSE RemoteApp (i.e. the one that has a “DisplayName” value of “WSE RemoteApp 2012 R2”), and then double-click on its “NoRemove” entry and change it from a 1 to a 0.

3) Open the “Programs and Features” Control Panel applet (i.e. right-click on Start -> Control Panel -> Programs and Features), locate the “WSE RemoteApp 2012 R2 Windows Server Solutions Add-in” program in the list of installed programs, and then go ahead and uninstall it from there instead.

  • You must to post comments.

I try to install another Addin Like “LightsOut” and that work greate.

  • You must to post comments.

Hallo Mike,


I think the problem ist that the service is not correctly created.

Look t the screenshot.

  • You must to post comments.

Hello Mike,

have upload the Log files to an Storage…

Here you can see the logs:

  • You must to post comments.

Thanks for the log files. I’m not exactly sure what’s going on there, but there’s something definitely wrong with the WSE RemoteApp Provider Service install on your server. As I mentioned previously, I’ve never seen this happen before, and to date, no one else is reporting a similar issue that I am aware of (and the way that the service is being installed/updated hasn’t changed in the slightest since the add-in was very first released years ago now).

What version of WSE RemoteApp 2012 R2 do you currently have installed on your server? And what version are you attempting to upgrade to (the current release of WSE RemoteApp 2012 R2, as of this writing, is Version 1.255.1512.0)?

Have you tried completely uninstalling the add-in from your Essentials server, and then re-installing it again as I suggest previously? If so, do you run into the exact same issue? Also, when you completely uninstall it, please check to see that the WSE RemoteApp Provider Service was successfully removed from your Essentials server before you actually attempt to re-install the latest version of WSE RemoteApp 2012 R2. If it hasn’t been properly removed, then let me know and I’ll provide you with a set of manual uninstall instructions for the add-in so that you can make sure that it has been completely removed from your server before you attempt to re-install it again from scratch.

  • You must to post comments.

The Service are stopped on 11.04.2018, then I try to install the newer Version of the WSE Remote app from 26.04.2018 with the Reason that adding can’t installed. After that I uninstall the older once and since there I try to install from scratch.

The newest one don’t work also.

I wonder, when I open the services.msc I see the WSE RemoteApp provider Service without any Settings …but I don’t see the WSERAProviderService in the registry.

All Updates from Microsoft are installed.. I don’t know what happened with this Server…this one works very good for the lat three Years with the adding..


  • You must to post comments.
Showing 6 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox