RADC Default Connection Setup error (0x80070005)



One of my PCs keeps getting the following error every time it starts up.

What’s happening is that when I launch the PC the RADC Default Connection Setup starts and then it ends up with an error message

“Last task result: Cannot register (create) task. Access is denied due to an I/O error or a specific type of security error. (0x80070005)”

When I click OK it takes me directly to  RemoteApp and Desktop Connections and I can see WSE RemoteApp 2016 (Default Connection) already in there.

Not sure why this keeps popping up on this one PC, all others are fine.

Also I can accesall the published apps without an issue.

I tried uninstalling and installing the “Client Connector for WSE RemoteApp 2016” with no luck.

I also checked the Task Scheduler under RemoteApp and Desktop Connections Update and all 4 tasks are there and were successfully run.

Not quite sure what the issue could be on this perticular PC.

Any help would be appreciated.

Best regards,


  • You must to post comments.
Good Answer

WSE RemoteApp sets up a task on each of your client computers that validates its RADC default connection whenever a user logs on to the client computer (it’s just a simple validation check that happens very quickly and nothing continues to run on the client afterwards). For whatever reason, that particular client computer is running into an access denied error when the task executes (i.e. when the “C:\Program Files\The Office Maven\RADCDefaultConnectionValidator2.exe” program is run by the scheduled task and attempts to validate the RADC default connection registry settings on the client computer). I’ve never seen that particular error pop up before, and so I’m not exactly sure what’s going on there.

You might want to try running the following program on that particular client computer (and follow the prompts it gives) just to see if doing that happens to correct the issue for you:

C:\Program Files\The Office Maven\RADCDefaultConnectionSetup.exe

NOTE: There’s actually a shortcut setup for quickly running the above mentioned program (named “RADC Default Connection Setup“) that’s located within the “WSE RemoteApp 2016” program group on the client computer’s Start menu.

If that doesn’t resolve the issue for you (i.e. if you continue to get the same error), then probably the best thing for you to do is to simply disable the task so that it no longer runs on that one particular client computer. To do that, open up the Task Scheduler applet (on the client computer), and then go to the following location:

Task Scheduler Library\Microsoft\Windows\Windows Server Solutions

Then right-click on the “RADC Default Connection Validator” task, and click on “Disable” in the context menu that appears.

Doing that should stop the scheduled task from running, and hence, stop the error from popping up each time a user logs on to that client computer. That being said… You’ll probably need to repeat the process any time you install an updated version of WSE RemoteApp seeing as it will probably re-enable the task again.

  • You must to post comments.
Showing 1 result
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox