Quicken 2018 Problem using WSE RemoteApp 2012 R2


I am currently evaluating WSE RemoteApp 2012 R2 for home use in particular with Quicken 2018. I have been having some issues and have tried registering for “Community Support”. I registered yesterday and NEVER received an email response. I also tried two different times (yesterday and today) to use the “Lost Password” link to reset the password I never received, and that did not work either. HOW DO I GET ACCESS TO COMMUNITY SUPPORT???

UPDATE: I just discovered that I can submit a message to Community Support “as a guest” (which was NOT obvious, by-the-way) which is what I am now doing.

This is the problem I ran into so far with Quicken 2018:
========================================================Installing Quicken on my Server and setting up the RemoteApp worked fine without any issues. Also, using the Launchpad from my desktop computer to run and use Quicken was fine. I am running the data file (QDATA.QDF) from a folder on the server which seemed to work fine.

The problem occurred when I used the Quicken file menu to “backup” the data file. The default backup location shown was in the user document folder on my local computer. However, I have always saved my Quicken backups to a different folder on the server, NOT on my local computer. So I tried doing that. I changed the backup location to the server folder I wanted to use and proceeded to save the backup.

The backup seemed to save okay BUT after saving the backup, Quicken could NOT reload the data file. When I tried to manually open the data file, I received a message that the file was “in use” and could, therefore, not be opened. After rebooting the server, Quicken still could NOT open the file (I got the same error message that the file was “in use”). I also tried rebooting my local computer. That did NOT help at all (same error message). I then tried a file “unlocking” utility (i.e., IOBit Unlocker). Although that utility indicated that the Quicken data file was NOT locked, I tried unlocking it anyway. That appeared to work. After using that utility, I was able to open the data file in Quicken once again.

I have not yet tried to replicate this issue. Is this a known issue? Can’t I save my Quicken backup to the server? Do I have to save it locally? If I do have to save it locally, that means I would have to save it to “my” local computer when I run Quicken but my wife would have to save it to “her” computer when she uses Quicken — which means the most recent backup would be on the computer that was last used instead of in one specific location. Not good! Is this an issue with your program or with Quicken — or both? I’ve included the “File-in-Use” error message I received with this message.

Thank you.
Denis W. Repke

  • You must to post comments.
Good Answer

We regularly use Quicken 2017 with WSE RemoteApp and have never had any issues with it whatsoever. I personally have yet to look at Quicken 2018, but I assume that it is very similar to the existing 2017 version, and if so, it should also work just fine with WSE RemoteApp as well.

Since Quicken is a “per-user” application (meaning that each user has access to their very own Quicken data file), the best way to setup Quicken for use with WSE RemoteApp is to create a sub-folder named “Quicken” off of the specific user’s pre-existing “Users” server folder, and then store their Quicken .QDF file and Quicken .QDF-backup files within that user-specific Quicken sub-folder. For example, if your Essentials server’s “Users” server folder is located at “S:\ServerFolders\Users“, then the user “Mike” should be using the folder “S:\ServerFolders\Users\Mike\Quicken” to store their user-specific Quicken .QDF data file and backup files in (or in UNC format it would be “\\Shared Folders\Users\Mike\Quicken“).

Other than that, you could also use the “STORAGE” page of the server Dashboard to create a new server folder named “Quicken“, and only grant (full read and write) access to the folder to the specific user that will be using Quicken. The user can then store their .QDF and .QDF-backup files within that folder (i.e. “\\Shared Folders\Quicken“).

Hopefully that will resolve the issues you are currently having.


As for community support on my website… It clearly states on the Ask Question page (when you are not currently logged in) that you can post as a guest by simply proceeding to fill out the fields on the question form, or that you can log in or register in order to post as a registered user (so that you don’t have to wait for your question to be moderated in order for it to be posted to the site). The pinned Welcome to Questions & Answers post over on this site’s Questions page also clearly states this information as well. Thus, I’m not exactly sure how much more apparent I can make it for my users. If you have any suggestions, I’d love to hear them.

Lastly, I went and registered for the site just to make sure things are working properly… I typed in my desired Username and (valid) Email address on the register form, answered the required captcha question, and clicked the “Register” button. I was immediately sent an email message with a link asking me to set my password. When I click on the link, I was taken to a page on this site where I could type in my chosen password. From there, I was able to log in successfully (and update my profile, etc.). Thus, everything appears to be working just fine for me here.

Did you check your spam folder to make sure that the registration email sent to the email address you provided didn’t get trapped as junk in your email client? Are you certain that you entered in a valid email address (with no typos, etc.)?

  • You must to post comments.

Mike, thank you for the quick response.

First of all, as for posting a question in community support as a guest, this option is not obvious (nor mentioned) if you go through the “SUPPORT” tab on your website as I did. The only “apparent” options are to “View All Questions and Answers”, “Login” or “Register”. It would not have been an issue if I was able to register easily as should have been the case. However, for some unknown reason, your website does NOT like my primary email address (<<snip>>). When I registered with this address, I never received an email response. I did NOT receive any kind of error message or any indication that there was a problem with my email address so I assumed that I would quickly receive a response — but I never did. After not receiving a response for well over an hour, I tried again. Your system would NOT let me register again. It said that I was already registered. So I had to try requesting a new password instead but that didn’t work either. I tried this a couple of times. Again, there was no error message but I just never received a response (and, yes, I did check my “spam” folders and found nothing).

Later in the day, I tried once again to register, only this time using my secondary google email address (<<snip>>). This address worked and I quickly received an email response. So, for whatever reason, your system has no problem registering me with either of my email addresses but, for some reason, cannot send a response to my primary address “<<snip>>”.

As for my issues with Quicken 2018:
The “file-in-use” issue seems to be a one-time problem that just occurs the first time the Quicken data file is backed-up to the server. On my primary computer, the issue only occurred the very first time I did the backup. The next several times, after doing a backup to the server, the data file reloaded without any issues. When I set Quicken up for the first time on my wife’s computer, there was a similar, but slightly different, issue. On her computer, after doing the first backup to the server, as was the case with my computer, the Quicken data file would not reload automatically after the backup. However, I was able to reload the data file just by clicking on its name in the Quicken “file” menu. I did NOT get a “file-in-use” error. Furthermore, as with my computer, this issue did not occur with subsequent backups.

As for the way I use Quicken, I don’t want to use it as a “per-user” application. I have always used a single data file for all of mine and my wife’s financial data and see no reason to separate our financial data into two files. Everything is much simpler with one file. I use a “ServerFolders\Documents\Quicken\Quicken Data” folder to store the Quicken data file(s) and a separate “Backup” folder for the backups. I use the “ServerFolders\Documents\Quicken” folder instead of using a separate “ServerFolders\Quicken” folder. This works well for our needs. I just want to use your program to give my wife easy access to our financial data. Hopefully, I won’t have any more issues.

  • You must to post comments.

I’m not exactly sure why you aren’t receiving an email back from the site when using your primary email address to register. I’m not able to replicate the problem here, and to date, no one else has mentioned a similar problem that I am aware of. I am glad to hear that you were able to work around the issue by using a secondary email address in order to register on the site.

I’ve updated the support page in order to try and make it a bit easier for folks who want to use our Questions & Answers forum as a guest. I’ve added a “Continue as a guest” option, and I’ve also made it a bit more apparent on the “Ask Question” page that you can post as a guest by simply filling out the fields on the page (without the need to log in or register). Again, the main advantage to registering an account is so that you don’t need to wait for your questions to be moderated before they get posted in our Questions & Answers forum.

As for your issue with Quicken… I’m glad to hear that it appears to be working properly for you now. Thanks for letting me know.

  • You must to post comments.
Showing 3 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox