QuickBooks error


My client reported to me that he can’t get into QB Enterprise using WSE RemoteApp 2012 R2.  He was successful yesterday, but today it gives an error.  He is trying a System Restore to yesterday morning to see if that resolves it and will report back to me.

The error occurs after logging into QuickBooks.  It has a couple of dialog boxes about reports, then pops up an error message with the code 19758 66888.  I didn’t find anything online about that QB error code.

The same user is successful when using a different computer at the same remote location with the same credentials and the same QB data file.

What would you suggest is the issue with the computer?  If the symptom goes away with System Restore, we’ll do some more testing and then updating.

Thank you for your help with this.

  • You must to post comments.

I’m not exactly sure what’s going on there, but it does sound like an issue with QuickBooks itself and not with WSE RemoteApp. Basically, all WSE RemoteApp is doing is initiating the secure RemoteApp session with the server, and then launching QuickBooks as a RemoteApp. After that, it gets out of the way and lets the remote application do whatever it needs to do.

I’m not seeing any notable issues with QuickBooks over here on any of our in-house test servers, and to date, no one else is reporting a similar error that I am aware of.

Thus, have you tried rebooting BOTH the server AND the client computer just to see if that happens to shake things loose for you?

Do you know if QuickBooks was recently updated? Were any Windows Updates installed on the server right before the problem started occurring? If not, then does BOTH the server AND the client computer have all of the latest Windows Updates installed?

Other than that, can you post a screenshot of the error messages so that I can get a better idea of what exactly is happening?

Lastly, have you followed NOTE #3 shown at the very bottom of this KB article that’s posted over on my website:

Install QuickBooks/Quicken On Your Server

And, I assume that you’ve seen this one as well:

Remove “Internet Security Levels Are Set Too High” Message

  • You must to post comments.

The odd part about this is that it is just one computer that is showing the problem.

The server had been rebooted yesterday, which may be related.  The one user was successful with remotely running QB on Wednesday but not on Thursday after the server reboot.  It is likely that there were Windows updates that installed on the server as part of the reboot.

The workstation should be current on Windows updates.  According to the user, the last update was before the last time he successfully ran QB.

I looked at note 3 in your first link.  The server was set to keep QB running.  I’ve since disabled that.

I looked at your second link.  Though we’re not getting that message, I checked the settings.  IE Enhanced Security Configuration was already off.  The Internet zone Security settings are set to Custom.  I don’t know what was changed in there.  I’ve done a backup of them from the registry but will put off resetting them until further testing.

I’m skeptical about this being an issue on the server as it works for other workstations, both remote and local.


  • You must to post comments.

I got my hands on the laptop yesterday and it has gotten more “interesting”.

I found that there was a hardware problem with the hard drive, so I put in a new one and started from scratch.  I installed Windows 10 and copied over some data from the old drive.  I copied an RDP file that works fine on my computer, but the problem persists!

I created a different user on the workstation, on the server, and in QuickBooks.  It shows the same problem.

I can successfully run QB remotely from a variety of other computers using the same credentials (both for the remote connection and for QB), just not this one laptop.  I ran a Windows Memory Diagnostic and it reported no errors.

What could be going on in the workstation that affects the remote application?


  • You must to post comments.

Oddly enough, the issue resolved itself!

What may have made the difference was logging into the server directly with the user’s credentials, starting QB with his credentials, then logging out of both.

It still makes no sense to me why the symptoms were different when the same credentials were used on any computer except the “problem” one, but at least it’s resolved now!

  • You must to post comments.

Thank you for your input on this issue.  Feel free to delete this thread if it seems appropriate.

  • You must to post comments.

I spoke too quickly.

The error would occur before the QB desktop occurred originally.  Once I saw that this was working, I assumed it was fixed.  The same error comes up now when you try to create a new invoice.

As before, I can log into the server as the same user, log into QB as that user, and it works without error.

I can connect with WSE through a different computer, same user as the problem one, and it works fine.

What could there be in the computer that affects QB running on the server?


  • You must to post comments.
Showing 6 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox