All Answers

0 votes

Hi Mike,

understand my in the right way: I don’t mean you should make all your work for “free” available! I only intend to avoid license activation issues for regular customers, even when support ends, or you decide to take the website down.

Best regards and thanks for the great work

Lars

0 votes

Hi all WSEE users,

the most important point for me is: Will the license check be “reconfigured” in the last package. At the moment I will use the WSEE after the EoS time, perhaps setup a new Server 2025 with it.

It would be very nice, if this will be possible, and no license check or transverse would be necessary.

Many thanks for the great work on WSEE!

Best regards

Lars

0 votes

Thanks homeserverdude, for your super detailed response.

Due to working fulltime and caring of  a 68 year year old following hip replacement surgery,at night, I haven’t had the chance to get back to the server…or your post.

I hope to get to the server today. Again , thanks so much for your response.

Eoin Remiskeet 🙂

0 votes

After verifying that there is no data whatsoever in the Server Folders on the system drive, you should be able to just delete them. After that start up the WSEE Dashboard and go to the storage tab. You should see complaints that the server folders are missing. The dashboard wizard should allow you to recreate the folders and point them at their locations on other drives with your existing data in place. You may have to recreate any custom shares that you previously had that aren’t setup by default (anything that’s not Company, File History Backups, Folder Redirection, Client Computer Backups, Users)

This method has worked for me numerous times over the years after doing a fresh install, migrating to another server, etc, but as always YMMV, so be cautious and preferably have a backup of anything important.

Another thing to note, if it’s just a matter of reinstalling WSEE on the same server after removing it without doing a fresh install of Windows itself, then things should (hopefully) be fairly smooth.

If you did a fresh install of the OS and created a new Domain, etc. then you might have to wrestle with NTFS permissions, along with recreating user accounts, etc. The Client Computer Backups should be visible, but they’ll likely show as Archived since you’ll have to remove client PC’s from the old domain, and rejoin them to the new one. There is also a tool from ForensIT I have used several times to in-place migrate user accounts on client pc’s to the new domain without having to create a fresh profile and losing all of the settings.

Not sure what your exact situation is with reinstalling, but I figured I would give some extra info that might be helpful. Maybe Mike can chime in on this too.

0 votes

Hi Mike

I did a reg backup and then delete the fore mentioned branch. Installer has started.

Thanks so much ! 🙏

0 votes

Thanks Mike, I’ll give that a try 👍

0 votes

Hmmm… That is a bit of a pickle now isn’t it. :- O

Try deleting the “89358BF37F6C1FF40940E32865754FBA” registry branch from the server under: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products

Then try running the latest WSEE Installer again.

Does that help any?

  • Mike answered 2 months ago
0 votes

As I said, I tried the full reinstall and nothing.

The only thing I have not tried is to uninstall WSEE as well.

I guess since this is hitting end of life I should be looking for other alternatives any way.

Thanks for your help and products.

  • Kal answered 2 months ago
0 votes

Everything is on latest.

I followed the instructions still same issue.

The error is on the WSERA.ServerSetup.log file but it is too big. That is what I had on the onedrive link, not sure why you are not able to open it. I tested it with a private window and it works fine.

Here are the lines that have error:

MSI (s) (3C:28) [22:16:23:394]: PROPERTY CHANGE: Adding WSERARDWebErrorDir property. Its value is ‘C:\Program Files\The Office Maven\WSE RemoteApp\RDWeb\Error\’.

MSI (s) (3C:28) [22:16:23:608]: Dir (target): Key: WSERARDWebErrorDir , Object: C:\Program Files\The Office Maven\WSE RemoteApp\RDWeb\Error\

MSI (s) (3C:D0) [22:16:24:580]: Hello, I’m your 64bit Elevated Non-remapped custom action server.
SchedSecureObjectsRollback: Failed to store ACL rollback information with error 0x80070003 – continuing

MSI (s) (3C!A0) [22:16:24:725]: MSI_LUA : Custom Action ‘ExecSecureObjectsRollback_64’ is running with sufficient privileges.
Action ended 22:16:24: ExecSecureObjectsRollback_64. Return value 1.
SchedSecureObjectsRollback: Failed to store ACL rollback information with error 0x80070002 – continuing

MSI (s) (3C:D8) [22:16:30:345]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI60C8.tmp, Entrypoint: ExecSecureObjects
ExecSecureObjects: Error 0x80070002: failed to get security info for object: CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder
CustomAction ExecSecureObjects_64 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 22:16:30: InstallFinalize. Return value 3.

MSI (s) (3C:28) [22:16:34:115]: Error in rollback skipped. Return: 5

MSI (s) (3C:28) [22:16:34:175]: Windows Installer installed the product. Product Name: WSE RemoteApp Windows Server Solutions Add-in. Product Version: 1.255.2103.0. Product Language: 1033. Manufacturer: The Office Maven. Installation success or error status: 1603.

MSI (s) (3C:28) [22:16:34:183]: Deferring clean up of packages/files, if any exist
MSI (s) (3C:28) [22:16:34:187]: MainEngineThread is returning 1603
MSI (s) (3C:20) [22:16:34:195]: RESTART MANAGER: Session closed.
MSI (s) (3C:20) [22:16:34:200]: No System Restore sequence number for this installation.
MSI (s) (3C:20) [22:16:34:210]: User policy value ‘DisableRollback’ is 0
MSI (s) (3C:20) [22:16:34:216]: Machine policy value ‘DisableRollback’ is 0
MSI (s) (3C:20) [22:16:34:221]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (3C:20) [22:16:34:225]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (3C:20) [22:16:34:230]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (3C:20) [22:16:34:235]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (s) (3C:20) [22:16:34:240]: Destroying RemoteAPI object.
MSI (s) (3C:40) [22:16:34:245]: Custom Action Manager thread ending.
MSI (c) (60:20) [22:16:34:251]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (60:20) [22:16:34:256]: MainEngineThread is returning 1603
=== Verbose logging stopped: 12/07/2026 22:16:34 ===

 

Nothing in C:\Program Files\The Office Maven\WSE RemoteApp\RDWeb\Error\, `WSE RemoteApp` does not even exist.

  • Kal answered 2 months ago
0 votes

I’m not seeing much in that log blurb that you posted, and I can’t access your one drive logs. So…

Are you running the WSE RemoteApp Updater from the server, or from one of your connected client computer? If the later, then try running it directly from the server instead.

Is the WSEE Installer on your Windows Server 2022 up-to-date? If not, then download the latest WSEE Updater from here.

If the latest release of WSE RemoteApp still won’t install, then you might want to try completely removing it from your Essentials server, rebooting, and then installing it again. To do so… Open the server Dashboard, go to the “APPLICATIONS” page, select the WSE RemoteApp add-in, and then click on the “Remove the add-in” task. Reboot the server afterwards, and then reinstall WSE RemoteApp via the latest full installer that can be downloaded from here.

Other than that… Take a look in the server’s “Logs” folder to see if any of the logs in there give any additional information as to why the installation is failing. You can find the server’s Logs folder here:

C:\ProgramData\Microsoft\Windows Server\Logs

If you sort the folder by date modified, then the most recently written to log files will appear up at the top of the folder.

You might also want to take a look in the Windows Logs -> Application log of the Event Viewer to see if anything of interest shows up in there as well.

  • Mike answered 2 months ago
  • last active 2 months ago
0 votes

Hi Mike,

Thanks for the quick reply. I tried the file deletion then run the latest install and got the same error.

What is interesting is that the files got recreated.

While following your guide I saw a log folder and this is what I see in there after the install:

———————————————————
[44540] 260710.213032.9416: Addins: Parsed command line args for InstallAddin.exe. Path=C:\Users\Administrator.TECHNOBUG\AppData\Local\Temp\n0d5uu0f.wssx,Silent=False,ClientInstall=False
[44540] 260710.213033.1727: General: VerifyPackageResult=OkToInstall
[44540] 260710.213033.1757: General: DoInstall=True
[29272] 260710.213033.2667: Addins: Looking for EULA at: Eula-en-GB.rtf
[29272] 260710.213033.2692: Addins: Looking for EULA at: Eula-en.rtf
[29272] 260710.213033.2692: Addins: Extracting EULA: Eula.rtf
[44540] 260710.213033.5742: General: VerifyPackageResult=OkToInstall
[44540] 260710.213033.5748: General: DoInstall=True
[44540] 260710.213033.7078: InstallAddinWizard: Created wizard with addin of type: Microsoft.WindowsServerSolutions.Console.AddIns.AddinPackages.PackageAddin
[44540] 260710.213052.7363: Addins: Async operation did not complete: Error=Microsoft.WindowsServerSolutions.AddinInfrastructure.AddInException: InstallError
   at Microsoft.WindowsServerSolutions.AddinInfrastructure.AddInManager.PerformAction[T](ProviderConnector`1 connector, Action`1 action, Boolean waitForCallback)
   at Microsoft.WindowsServerSolutions.AddinInfrastructure.AddInManager.<>c__DisplayClass66_0.<InstallAddInAsync>b__0(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
[44540] 260710.213052.7403: Exception:
—————————————
An exception of type ‘Type: Microsoft.WindowsServerSolutions.AddinInfrastructure.AddInException, AddinInfrastructure, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ has occurred.
Timestamp: 07/10/2026 21:30:52
Message: InstallError
Stack:    at Microsoft.WindowsServerSolutions.AddinInfrastructure.AddInManager.PerformAction[T](ProviderConnector`1 connector, Action`1 action, Boolean waitForCallback)
   at Microsoft.WindowsServerSolutions.AddinInfrastructure.AddInManager.<>c__DisplayClass66_0.<InstallAddInAsync>b__0(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
[44540] 260710.213057.0268: Addins: Exiting with return code: -1
  • Kal answered 2 months ago
1 vote

Hmm… I’m not exactly sure what’s going on there. Please try the following to see if it resolves the issue for you:

1. Sign in to your Essentials server as an Administrator.

2. Open the following folder on the Essentials server:

C:\ProgramData\Microsoft\Windows Server\Data\addins

NOTE: The ProgramData folder is a hidden system folder, and so you’ll need to enable the viewing of hidden files and folders in order for you to be able to see its contents. That can be done using the “Folder Options” Control Panel applet (via its “View” tab).

3. In the “packages” subfolder, delete the file named “009ef2c9-1a5c-4564-8156-92b85d9d7705.wssx” (if it exists).

4. In the “msi” subfolder, delete the entire subfolder named “009ef2c9-1a5c-4564-8156-92b85d9d7705” (if it exists).

5. Open the following folder on the Essentials server:

C:\ProgramData\Microsoft\Windows Server\Data\settingsproviderdata\WEBSERVICESPLATFORM\ADDINS

6. Look through all of the .xml files that are in that folder until you find the one that corresponds to WSE RemoteApp (just double click on the .xml file to open it in the web browser, or you can open it in any text-based reader app such as Notepad, WordPad, etc. and then search its text contents for “WSE RemoteApp” to know that you’ve located the correct .xml file). Once you’ve located the correct .xml file, go ahead and delete it from your Essentials server (note that you can also delete its corresponding .bak file as well).

NOTE: This simple text-based file contains installation information, etc. about the WSE RemoteApp add-in (such as its version number, etc.). It will be automatically recreated the next time you perform an installation of the add-in.

7. Download the latest release of the WSE RemoteApp Updater from here (as of this writing, the current/minimum release is Version 1.255.2103.0).

8. Run the WSE RemoteApp Updater program from the desktop of the Essentials server.

Does that resolve the issue for you?

  • Mike answered 2 months ago
  • last active 2 months ago
0 votes

Under Windows Server 2022 there’s an issue (bug) that causes the user to be automatically opted-out of the “Get updates for other Microsoft products” task whenever a new virus definition set is installed by Windows Update. I’m not sure if the bug still exists in the most recent releases of 2022, and I was under the impression that the bug didn’t exist at all under 2025 (but maybe it does).

So… The WSEE Installer has code in it that checks to see if the task isn’t already opted-in (when running under 2022), and if not, it then goes ahead and forces the opt-in for you (via a call to the native method that does that within the underlying Essentials source code) and then it clears the “Microsoft Update is not enabled” health alert if it happens to exist.

I’ll go ahead and enable that fix for 2025 as well under the next release of the WSEE Installer/Updater (which should be out on July 14 with the next release of Windows Updates). Hopefully that resolves the issue for you (although, that being said, I’m not seeing the issue happen over here on any of our 2025 Essentials servers as all of them have the task enabled just fine via the HOME -> Get Started -> SETUP panel of the server Dashboard).

Lastly, the “Get updates for other Microsoft products” task within TaskStatus.xml has a key value of 8412D35A-13EE-4112-AE0B-F7DBC83EA83D (and mine shows all 9 task status entries). However, you probably shouldn’t manually enable it within that file if it hasn’t truly been enabled (i.e., maybe wait for the fix I release before resorting to doing that).

  • Mike answered 3 months ago
1 vote

Those FreeDNS tasks are still working just fine for me here, and to date, no one else has mentioned an issue with them. Probably the best thing for you to do would be to open the Task Scheduler applet on your Essentials server, go to Task Scheduler Library\Microsoft\Windows\PowerShell\ScheduledJobs, take a look at the “RunFreeDnsUpdate” and “StartFreeDnsJob” tasks and make sure that everything looks as expected (i.e., the Triggers, Actions, etc.). Looking at the task’s History may also prove to be helpful for you as well.

Otherwise, you can try using the Duck DNS script instead (I actually have both of them running on my main Essentials server – just for the heck of it).

EDIT: BTW, you can also open the Event Viewer applet on your Essentials server and take a look at the Windows Logs\Application log and filter it on the event source named “FreeDNS Updater” just to see if any errors or warnings are getting logged.

  • Mike answered 4 months ago
  • last active 4 months ago
0 votes

Mike,

I started reading the microsoft links you provided and it looks like most or all of the restore feature questions I just posed are answered there. Should I have additional questions after re-reading, I’ll circle back.

0 votes

Chewing on all this. Thanks for the specific answers, Mike.

Apologies for confusing WSEE behaviors with a third-party software. Specific to the WSEE’s restore features, will it allow:

  1. restoration of an entire disk image?
  2. the ability to choose to restore a particular drive volume?
  3. the ability to choose individual files and folders to restore?
1 vote

Unfortunately, WSEE cannot be setup in a workgroup. It must either be or see a domain controller. That being said, you can skip domain joining your client computers so that they behave in the same way as your WHS clients did. SEE: How to make Windows Server 2012 R2 Essentials client connector install behave just like Windows Home Server

While you should indeed assign a static IPv4 LAN network address to your server (and then point the DNS of your connected client computers to it – see here), WSEE will work just fine with a dynamic IP address from your ISP (for use with the server’s built-in Anywhere Access/Remote Web Access website). If you use a .remotewebaccess.com Microsoft personalized domain name (which is exactly the same as using a .windowshomeserver.com domain in WHS), then Microsoft provides a dynamic DNS update service that will keep your dynamic IP address correctly pointed to the server for you (just as WHS did).

As for backup and restore… It should be able to do all of those things you’ve mentioned. I’m unfamiliar with Stablebit, but WSEE has it’s own drive pool feature built in (called Storage Spaces) and the backup and restore features work just fine with it. You’ll need to test things out for yourself to make sure that they work the way you desire (as far as Stablebit is concerned). However, if you were able to do it in WHS, then I imagine that you’ll be able to do it in WSEE no problem.

SERVER BACKUP
Set up or customize server backup
Manage Server Backup in Windows Server Essentials
How to backup and restore your Windows Server Essentials 2016

CLIENT BACKUP
Restore a full system from an existing client computer backup
Manage Client Computer Backup in Windows Server Essentials
How computer backup works
Troubleshoot computer backup and restore errors in Windows Server Essentials

  • Mike answered 4 months ago
  • last active 4 months ago
0 votes

Yes, I just found that out as well. Also had to make sure the admin account I was using had all the right permissions and then rebooted before running adprep.

Updated completed and WSEE reinstalled – just now working through any further optimisations I can now make, but all looking good (so far).

Server 2025 did take a good few hours working at 99% of the upgrade, but eventually got there!

2 votes

It appears that you will still need to do an adprep in order to successfully in-place upgrade to Windows Server 2025 via the Feature Update that’s now available from Windows Update (see the 5/2/2026 bullet point here). However, it’s easy to do that as follows…

From your Essentials server, open Windows Update, click “Check for Updates” (if required), and then begin installing the Feature Update to Windows Server 2025 by clicking on the “Download and install” link.

During the Feature Update installation of Windows Server 2025 (at around 35%) a “What needs your attention” window will be shown (with a completely blank/empty list of things!). From here you will need to do the following:

• Click StartWindows Administrative ToolsActive Directory Users and Computers

• Under “Users“, double-click on your Essentials server’s administrator name, and in the Properties dialog box that appears, click on the “Member Of” tab, click the “Add” button, type in “Schema Admins” (without the quotes), and click “OK“. Click the “Add” button again, type in “Enterprise Admins” (without the quotes), and then click “OK” twice.

• Sign out and sign back in again (required!).

• Click Start → type “Command Prompt” (without the quotes) and then right click on Command Prompt and select “Run as administrator” from the context menu that appears.

• From the admin command prompt that appears run these two commands:

C:\$WINDOWS.~BT\support\adprep\adprep /forestprep
C:\$WINDOWS.~BT\support\adprep\adprep /domainprep

• Open Windows Update again and click the “Download and install” link (or click the “Fix issues” button if it’s available) to resume the installation.

NOTE: Microsoft will forcefully remove all of the “Essentials bits” from the server during the in-place upgrade, and so you will need to run the WSEE Installer after performing the in-place upgrade in order to reinstall WSEE onto the server again. All of your existing users, devices, settings, client backups, etc. will remain in tact throughout the entire process.

  • Mike answered 4 months ago
  • last active 4 months ago
Showing 1 - 20 of 670 results

Featured Questions

Recent Questions & Answers

Q&A Toolbox