WSERA.Client.exe cannot connect to applications



I’ve been upgrading your WSE 2012 R2 remoteapp application already numerous times but last time I did something went wrong during the upgrade procedure. As a result the shortcut in the Launchpad and on the remoteapp folder on the desktop isn’t working anymore. When you click the icon or the name of any remote application you will see the system show the progress icon and then it simply stops and nothing happens anymore.

I assume that the parameters for the WSERA.client.exe are not configured correctly and therefore the connection fails.

I tried alredy to remove the remoteapp implementation for my server account and remount it afterwards but no success.

Any suggestion?


Bart Pen

  • You must to post comments.
Best Answer

This is most likely caused by your Windows 10 client computer having the older v10.0.10240.16384 “Windows Server Essentials Connector” software installed on it (i.e. the older version that gets installed as a Windows Update instead of as a standard program). The problem does not occur when the newer v10.0.14393.0 “Client Connector for Windows Server Essentials” software is installed (i.e. the newer version that gets installed as a standard program instead of as a Windows Update and can survive Windows 10 feature upgrades).

That being said… The issue has since been resolved in the latest version of WSE RemoteApp 2012 R2 (i.e. Version 1.255.1261.0 or greater). You can download the latest update from within the server Dashboard application. Just install it over the top of your existing install, and you “should” be good to go.

Alternatively, you can uninstall the older Connector software from your Windows 10 client computer, and install the newest version as follows:

1) Make sure that your server has KB3172614 installed on it (which has the updated “inbox component” for delivering the newer Connector software to your Windows 10 client computers). I believe that this is now a mandatory update, and so as long as your server has all of the latest Windows Updates installed, you should already have it.

2) On your Windows 10 client computer, open the “Programs and Features” Control Panel applet.

3) Locate the “WSE RemoteApp 2012 R2 (32-bit/64-bit) Launchpad Add-in Deployment” (or “Client Connector for WSE RemoteApp 2012 R2“) program and uninstall it.

4) In the “Programs and Features” Control Panel applet, click on the “View installed updates” link (which is located in the top left-hand corner of the window), and then search for the “Windows Server Essentials Connector” update and uninstall it.

5) Reconnect your Windows 10 client computer to the server by going to:


Doing that will download the latest version of the Connector software (which is v10.0.14393.0 as of this writing), and install it on your Windows 10 client computer.

6) Reinstall the WSE RemoteApp 2012 R2 client-side connector software on your Windows 10 client computer(s) by opening the server Dashboard application, going to the “APPLICATIONS” page, selecting the “WSE RemoteApp” add-in, and clicking on the “Install the add-in on network computers” task.

Obviously, it’s far easier/faster to just install the latest version of WSE RemoteApp 2012 R2, but if you’d like to make sure that you have the latest Connector software on your Windows 10 client computer(s) (so that you don’t run into any issues down the road when additional Windows 10 feature upgrades are released by Microsoft), then you can take the harder/longer route mentioned above.

  • You must to post comments.

Hi Mike,

Unfortunately this is not the issue. This issue that you described is something that I found out a long time ago. Meanwhile have implemented the procedure described by you already some months ago.

My issue happened after I had already implemented several updates on Win 10 without having to reconnect everything again.

The exact cause I don’t know but I do know for sure that this problem occurred while I was doing an update on the sever and some other application started to give me some pop-up windows  at the same time. I must have clicked the wrong button in the wrong window somehow (fingers faster than the mind…).

Anyway, the situation corrected itself. Yesterday I installed a new update on the sever and automatically this update was distributed to the clients. Once this update was installed on my win 10 client system the issue was solved. I assume that the access code to the application on the sever got corrupted or was still the old code. After the upgrade this code was replaced by the new, correct code and everything was back to normal.

Thank you for your time.

  • You must to post comments.

I’m glad to hear that the latest release of WSE RemoteApp 2012 R2 resolved the issue for you. A whole lot of work went into this new version in order to enhance the client-side connector (WSERA.Client.exe).

Previous versions of WSE RemoteApp 2012 R2 distributed some of the Essentials SDK assemblies in order to work around a bug that exists in version 10.0.10240.16384 of the Essentials client Connector software. Microsoft (somewhat) resolved the issue with their newest release of the Connector software (i.e. version 10.0.10586.63, 10.0.14393.0, or later), and so I decided to go ahead and remove the extraneous SDK assemblies from the later versions of WSE RemoteApp. However, I quickly found out that many users still have the older Connector software installed on their Windows 10 client computers because Microsoft doesn’t actually offer an upgrade path to the newest version of the Connector software (rather you have to manually go through the whole mess of making sure that you have the July update rollup installed on your server, uninstalling WSE RemoteApp and the older Connector software from your Windows 10 clients, and then reconnecting all of the clients with the server again).

Anyway… One of the additional enhancements I made to WSERA.Client.exe was to make it so that it now shows details about the client computer within its “About” dialog box (including the version of the Connector software that you have installed on your client computer). Thus, I’d be interest to hear what version it reports for the Connector software installed on your Windows 10 client computer. My guess it that it will show the older (and problematic) 10.0.10240.16384 version. To check, simply click on the “WSE RemoteApp Launcher” shortcut on your Windows 10 client computer’s desktop, and then click on the “About” link. Once the “About WSE RemoteApp 2012 R2 Client Connector” window appears, click on its (new) “Show client details” button, and then note the “Launchpad version” information that’s shown there.

Regardless, at least you’re back up and running again.

  • You must to post comments.
Showing 3 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox