Remote App 2016


Hi Office Maven,

I have the current update of Remote App for server 2016 installed but after installing the latest server updates it is only allowing 2 users to log in, then says Remote Desktop Services is busy.

Is there a new update to resolve this issue.



  • Damien McGrath asked 5 years ago
  • last edited 5 years ago
  • You must to post comments.
Best Answer

I’m not sure about the “Remote Desktop Services is busy” error that you’re getting, as I’ve not come across that one before. Hopefully, a server restart (see below) will resolve that issue for you as well.

As for only 2 users being able to log on to WSE RemoteApp… Open the server Dashboard, go to the “WSE REMOTEAPP” page, click on the “Enable Simultaneous Connections” task, follow the prompts, and be sure to restart your server when you are prompted to do so. If for some reason the task tells you that multiple simultaneous connections are already enabled on your server (when you know for certain that they aren’t), then try holding down the SHIFT key on your keyboard while you click on the “Enable Simultaneous Connections” task. Doing that will force the task to go ahead and enable itself once again.

  • You must to post comments.
Showing 1 result
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox