Error: Application tampering suspected


Earlier this week I’ve upgraded our WSE RA installation on Windows Server 2016 to the latest version (June 30th release). After this update the application gave me an “Application tampering suspected” error message when running most of the commands from the “Users tasks” list. It says it’s “Unable to validate digital signature of required assemblies”. However the WSE RA Apps are still working.

I’ve already tried reinstalling, but the installer tells me that we’re already on the latest version of the App.

Not sure if error occurred because of the update. It might have been there before the upgrade. It’s just that I noticed right after the upgrade.

Do you have any suggestion on how I can resolve this error?

Thanks in advance,

Tom van der Geer

  • Tom van der Geer asked 2 years ago
  • last edited 2 years ago
  • You must to post comments.
Good Answer

I’m not exactly sure what’s going on there seeing as I’m unable to reproduce that one (under the latest Version 1.255.1953.0 release), and to date, no one else is reporting a similar issue that I am aware of. WSE RemoteApp does have code in place that checks its assemblies for a valid digital signature (in order to ensure that they haven’t been tampered with), but I am unaware of any issues with that portion of the code (which has been in place for many years now).

Out of curiosity have you tried restarting your server just to see if that helps shake things loose for you? Other than that, does your server have all of the latest Windows Updates installed on it, and does it have a working Internet connection?

  • You must to post comments.
Showing 1 result
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox