After Disk Changes, WSEE Management Service Fails Start



I had a virtual disk fail on my RAID controller. Since I wasn’t really using this disk for anything, I decided to just pull the physical drives out of the server and move on with my life. However, with virtual disk gone, now my Windows Server Essentials Management Service will no longer start. I get no particular interesting information from the Event Log – Event ID 7031 “The Windows Server Essentials Management Service service terminated unexpectedly. It has done this 24 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.”

Additionally, Windows Server Backup MSC will not load. I get “A fatal error occurred during a Windows Server Backup snap-in (Wbadmin.msc) operation. Error Details: The server threw and exception. Close Wbadmin.msc and then restart it.”

I assume these two errors are connected and are in fact the same error, meaning I assume whatever underlying .NET phenomenon is causing Windows Backup to crash is also causing WSE Management to crash, or vice-versa. And I assume this has something to do with the missing disk. What I don’t know is where this information about the disk might be stored or how to clear it out.

I also have these messages in my Application Event Log (correlated with the crash of the services):

Event 1000
Faulting application name: bad_module_info, version:, time stamp: 0x00000000
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xe0434352
Fault offset: 0x00007ff83d521b29
Faulting process id: 0x2894
Faulting application start time: 0x01dab5177931320b
Faulting application path: bad_module_info
Faulting module path: unknown
Report Id: 6f56166d-bab3-4d1f-a99b-b872c4079cad
Faulting package full name:
Faulting package-relative application ID:

Event 1026

Application: SharedServiceHost.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: Microsoft.SnapIns.Backup.UI.Proxy.BlockLevelBackupException
at Microsoft.SnapIns.Backup.UI.Proxy.HResultHelper.HRToException(Int32, System.String)
at Microsoft.SnapIns.Backup.UI.Proxy.ManagedProxy.QueryTemplates()
at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.BlbProxy.PerformRetriableAction[[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.Func`2<Microsoft.SnapIns.Backup.UI.Proxy.ManagedProxy,System.__Canon>, System.String)
at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.ServerBackupWorker.GetScheduledBackupPolicy(System.Collections.ArrayList)

Exception Info: Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.ServerBackupLibException
at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.ServerBackupWorker.GetScheduledBackupPolicy(System.Collections.ArrayList)
at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.ServerBackupWorker.get_PolicyExists()
at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.Provider.ServerBackupDevicePropertyReporter.GetServerBackupStatus()
at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.Provider.ServerBackupDevicePropertyReporter.UpdateServerBackupStatus()
at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.Provider.ServerBackupDevicePropertyReporter.<StartReporting>b__11_0()
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
at System.Threading.ThreadHelper.ThreadStart()

Have you ever seen anything like this before? Any ideas of how to “reset” Windows Server Backup / WSE Management read of available disks or clear out some reference to a disk that is no longer present and causing the services to crash?

What is method of last resort? Even if I lose all my previous backups I just need to get back up and running.

I found this article but I haven’t yet gone to the extent of trying to delete the backup catalog on the hopes that maybe you know something that can help me preserve my existing backups.

  • You must to post comments.

Thanks ArtinNC and Mike for the replies. Here’s my result.

First I tried


and I saw that I had one very old backup copy which targeted the missing disk. Thinking myself quite clever, I deleted that one backup with

wbadmin DELETE BACKUP -version:xx/xx/xxxx-xxxx.

After I did this, the Windows Server Essentials Management Service started.

I patted myself heartily on the back and prepared the champagne flutes.

However, I saw that the Windows Server Backup MMC still would not load. I put the flutes away and remembered that actually, I don’t drink.

I attempted to re-setup Server Backup through the WSEE Dashboard Wizard.

This process did not succeed, it crashed the Dashboard app, and once again caused the WSE Management Service to fail to start.

I eventually capitulated and ran

wbadmin delete catalog

After this, all services were able to start, the Windows Server Backup MMC loaded right up, and I was able to reconfigure backups… sadly while reformatting my backup disks in order to use them, thus wiping my historical backups. Let ye be warned… Windows Server Backup, she is a harsh mistress.

  • You must to post comments.

I’ve personally never come across a situation like this before, but I do know that the Windows Server Essentials Management Service can be really finicky about the specific disks that are installed/being used. Over the years, I’ve seen all kinds of issues being reported by various folks stating that the service won’t start or stay running due to the particular disks or disk configuration that they were using (RAID arrays, size of the disks, type of SSD, drivers, etc., etc.). I have no idea why things are so touchy in this area for some folks, but not for others. Guess that’s just one of the quarks that we all have to live with when using Essentials I’m afraid.

Thanks ArtinNC for your tip about deleting the Windows Backup catalog in order to resolve the service not starting/running issue. I haven’t come across that one before, but will definitely add it to my book of tricks. ;- )

  • You must to post comments.

I can tell you that Opening a Command Prompt (Admin) and running:

wbadmin delete catalog

will probably fix Windows Server Essentials Management Service not running.  I have a brand new 2019 server and a brand new WSEE install.  Everything was perfect until I configured server backup.  Then the Users disappeared because Management Services wasn’t running.  I have no idea what happened but I used the command above that I found at the link you posted and that got the service running.  I then configured backup again and this time there was no issue.  I have no idea why.  So although you will probably lose old backups, at least the command should get you running again.

  • You must to post comments.
Showing 3 results
Your Answer
Post as a guest by filling out the fields below, or you may to post using your existing user account (register to create a user account if you do not already have one). Guest's questions will be moderated before being posted. NOTE: Your email address will not be published, nor will it be used for marketing purposes, etc. (as per our privacy statement).
Answer Details*
File Name Size
There are currently no files uploaded.
Maximum number of files 4, maximum file size 5MB.
Supported file formats: gif jpeg jpg png

Featured Questions

Recent Questions & Answers

Q&A Toolbox